When I wrote up my qualifier papers in Word 2013, one thing that constantly bugged me was that whenever I added a reference to my paper using the built-in “Insert Citation” tool, the language field code of that bibliography field was set to Chinese even though I was clearly typing English. To see why this is problematic, consider this source:

Naylor, D., Mukerjee, M. K., Agyapong, P., Grandl, R., Kang, R., Machado, M., … & Steenkiste, P. (2014). XIA: architecting a more trustworthy and evolvable internet. ACM SIGCOMM Computer Communication Review, 44(3), 50-57.

The correct APA-style in-line citation should be (since I am writing the paper in English):

(Naylor, et al., 2014)

However, when the language field code is set to Chinese, Word 2013 generates this instead:

(Naylor, 以及其他人, 2014)

You can have Word 2013 show all the field codes by pressing Alt + F9:


As you can see, they both reference to the same source but with different field codes, 1033 for English and 2052 for Chinese.

There is no efficient way to bulk change field codes. One solution is to right-click on the bibliography field and choose “Edit Field”, where you can manually change the field code. That is easy if you have five sources, but painstaking if you have fifty. And no, you cannot “Find and Replace” field codes.

I wanted it so that a new bibliography automatically assumes English language instead of Chinese. I thought it was because of my language setting in Word/Office, so I tried changing it. Or rather, I tried changing THEM. The language setting in Word 2013 is confusing as hell. There is “Editing Language”, “Proofing Language”, “Display and Help Language”, “ScreenTip Language” as well as the language of a source itself.

Note the “Language” drop-down menu on the upper right corner of the “Create Source” window.

I had no idea which of these was the culprit so I tried changing all of them. It did not fix the problem. I even tried re-installing Office 2013, and changing “Language for non-Unicode Programs” in the Control Panel. Still no luck. My operating system language has always been in English, so it probably is not the cause.

After hours of frustration (and manually changing the field codes in 100+ references) I finally figured it out. As it turns out, none of the language settings in Word makes a difference in this case. What really matters is your system input language/keyboard. Word 2013 tries to be smart by matching your document language to your input language/keyboard so that (I guess) the correct formatting and proofing tool can be applied. The problem is that the input language/keyboard is not necessarily the actual language you are typing in. In my case, I was typing English with a Chinese keyboard, Sogou Pinyin. This particular keyboard has a toggle for Chinese/English output.

Notice that Sogou Pinyin allows me to type in English (“英”), but is technically a Chinese keyboard, as shown by the “CH” in the Windows Language bar

In order for Word 2013 to insert bibliography in English, the input language/keyboard must be switched to English, as shown below:


Admittedly you would only encounter this problem if you use a single keyboard (input method software) to type bilingually. I chose to do it this way because Sogou Pinyin allows me to switch between English/Chinese with only one key (Shift) while changing system input language/keyboard requires two keys (Ctrl + Space). Most Sogou Pinyin users I know still use the Ctrl + Space method, so I might be the minority here.

Regardless, I am gonna go ahead and assign blame. First of all, Office developers seem to believe that system input language/keyboard = actual language being typed, while other Windows software developers, i.e. Sogou, have made products that clearly violate that assumption. Microsoft needs to ensure that the internal and external interpretations of system input language/keyboard are consistent. Secondly, given that different developers make different assumptions about the operating system, if Office/Word had exposed just a little bit more about what was going on under the hood, I would not have wasted hours searching for the answer.